[CLOSED] PCOP + CentOS

Container for RESOLVED incidents, queries SOLVED by the experts, EXPIRED topics or those that have been CLOSED by the users
Locked
BazKid
Registered user
Registered user
Posts: 1
Joined: Thu, 27 Mar 2014, 10:48

[CLOSED] PCOP + CentOS

Post by BazKid » Sun, 30 Mar 2014, 03:06

Hi, I have a Centos 5 server and i'm trying to install PCOP with no success.
After running the instalation script i try to start PCOP Agent and it gives me the following errors:

./PCOPScheduler: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /opt/PCOPAgent/PCOPScheduler/lib/libPocoFoundation.so.9)
./PCOPScheduler: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/PCOPAgent/PCOPScheduler/lib/libPocoFoundation.so.9)
./PCOPScheduler: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/PCOPAgent/PCOPScheduler/lib/libPocoUtil.so.9)
./PCOPScheduler: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /opt/PCOPAgent/PCOPScheduler/lib/libPocoUtil.so.9)
./PCOPScheduler: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/PCOPAgent/PCOPScheduler/lib/libPocoXML.so.9)
./bin/PCOP_AgentService: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./bin/PCOP_AgentService)
./bin/PCOP_AgentService: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /opt/PCOPAgent/lib/libPocoFoundation.so.9)
./bin/PCOP_AgentService: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/PCOPAgent/lib/libPocoFoundation.so.9)
./bin/PCOP_AgentService: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/PCOPAgent/lib/libPocoUtil.so.9)
./bin/PCOP_AgentService: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /opt/PCOPAgent/lib/libPocoUtil.so.9)
./bin/PCOP_AgentService: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/PCOPAgent/lib/libPocoNet.so.9)
./bin/PCOP_AgentService: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/PCOPAgent/lib/libPocoNetSSL.so.9)
./bin/PCOP_AgentService: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/PCOPAgent/lib/libPocoXML.so.9)
./bin/PCOP_AgentService: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /opt/PCOPAgent/lib/libcurl.so.4)
./bin/PCOP_AgentService: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /opt/PCOPAgent/lib/libxml2.so.2)
./bin/PCOP_AgentService: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /opt/PCOPAgent/lib/libcrypto.so.0.9.8)

Any one with linux instalation of PCOP?

User avatar
James
Official moderator
Official moderator
Posts: 21
Joined: Thu, 17 May 2012, 16:14
Location: Florida
Contact:

Re: PCOP + CentOS

Post by James » Tue, 01 Apr 2014, 22:26

Can you run ldd --version and tell me what version number is listed?

Also, did you install the prerequisites?

PavSL application requires installation of the following libraries to function properly:
- libsoup-2.4.so.1 (HTTP client / server library for GNOME)
- libmcrypt.so.4 (MCrypt - encryption functions)
- libz.so.1 (zlib compression and decompression library)
Regards,

James
Pre-Sales Engineer, Panda Security USA
I don't reply to private messages unless I have previously requested them

Locked

Return to “Adaptive Defense and Endpoint Protection - Archive Issues”